PHP 8 and Wordpress

PHP 8 and Wordpress

PHP 8 was released recently, while WordPress still supports PHP 5.6. Supporting such a wide range of PHP versions in one codebase is challenging.

A main motivator for migrating to a new major version of PHP are new language features. Keeping backward compatibility to old PHP versions, however, prohibits the use of any new language features. What remains is the effort to make a project compatible with newer PHP versions, without a lot of tangible benefit.

At The Online PHP Conference, Juliette Reinders Folmer will use WordPress as an example to explain how existing code can be made compatible with PHP 8. Hardly anybody else could be more qualified, because Juliette is a WordPress committer and has rendered outstanding services to the PHP and WordPress communities, for example by creating the PHPUnit Polyfills and co-authoring PHPCompatibility.

Juliette is an opinionated, passionate busy-body with a prolific portfolio of contributions to various high profile Open Source projects over the years. She is self-employed and based in the Netherlands.

More about Juliette's presentation "PHP 8 and Legacy Code"