PHPUnit 5, PHP 7, and Beyond

New versions of PHPUnit that add new functionality are released bi-monthly. These releases do not break backwards compatibility, making it easy to stay up-to-date. PHPUnit 5.0, however, had to break backwards compatibility in October 2015 to support PHP 7. We will discuss how PHPUnit had to be adapted for PHP 7, how PHPUnit benefits from PHP 7, what additional changes PHPUnit 5.0-5.2 have brought, and we'll close with a look ahead to PHPUnit 6.

Slide 1 von 33

PDF

Über den Referenten

Sebastian Bergmann
Sebastian Bergmann
Twitter LinkedIn Xing
Vortrag teilen
Just married: Node.js and PHP The hidden cost of bad code (and how to avoid it)